FIXED
No components marked as affected
Investigating
The Sign up with google is working just fine but the form sign up is not.